[Canberrauav] MAVProxy "line noise"

Brucebaxtersolutions brucebaxtersolutions at gmail.com
Wed Dec 16 10:33:16 AEDT 2015


I never found why but suspect it may be some sort of over volts protection trying to limit it down, like crowbar protection, and that causes noise?

Sent from my iPad

> On 16 Dec 2015, at 8:36 AM, David C <cottrill.david at gmail.com> wrote:
> 
> This seems a much better direction than I was taking - thanks Bruce.
> 
> I can't see how the servo power supply would influence the noise characteristics on the serial data ground plane, but noise analysis in electronics is something of a dark art that I have little experience in.
> 
> 
>> On 16 December 2015 at 08:22, Brucebaxtersolutions <brucebaxtersolutions at gmail.com> wrote:
>> Try unplugging the speed controls and power it from a USB charger.
>> That was when I saw the problem go away.
>> 
>> Sent from my iPad
>> 
>> On 16 Dec 2015, at 12:17 AM, Alex Satrapa <grail at goldweb.com.au> wrote:
>> 
>> >> On 15 Dec 2015, at 09:49, Brucebaxtersolutions <brucebaxtersolutions at gmail.com> wrote:
>> >>
>> >> May be a long shot, but I had a lot of trouble with "noise" that was caused by voltage.
>> >> At 5.7v I couldn't get stable operation, but at 5.3v the problem disappeared completely.
>> >>
>> >> Turned out the external Bec was set to 6v instead of 5v.
>> >> Some speed controllers have a standard setting of 6v as well.
>> >
>> > My ESCs have built in BEC, they’re producing 6V but the power lines to the telemetry radio are 5.15V.
>> >
>> > I’ve tried the following, with no reduction in line noise:
>> >
>> > - Disconnecting all the servos.
>> > - Disconnecting the GPS and compass module.
>> > - Changing the orientation of the dipole antenna.
>> >
>> > Next challenge is to use the radios with USB connections between two computers, and just pump a few books worth of text over the wire. That should isolate it to being the radios versus the quadcopter platform.
>> >
>> > That might happen Thursday sometime. Tomorrow is electronics night at MHV and I’ll be working on my water level sensor …
>> >
>> > Alex
>> >
>> >
> 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://canberrauav.org.au/pipermail/canberrauav/attachments/20151216/ce4e0a9b/attachment.html>


More information about the Canberrauav mailing list